Payment Links Failing to Load

Incident Report for ConnexPay

Resolved

The incident has been resolved and payment links are now loading correctly.

We sincerely apologize for any inconvenience this may have caused. If you experience any further issues or have additional questions, please don't hesitate to reach out to our support team at Support@connexpay.com.

Thank you for your patience and understanding.
Posted Apr 29, 2026 - 19:35 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2026 - 19:24 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 29, 2026 - 19:18 EDT

Investigating

We are currently investigating a issue which is causing our ConnexPay payment links to fail to load. More information will be provided shortly.
Posted Apr 29, 2026 - 19:16 EDT
This incident affected: PayIns US (Hosted Payments Page).