Service Disruption Affecting Bridge UI Portal

Incident Report for ConnexPay

Resolved

The issue affecting the Bridge portal has been resolved, and the label dropdown used to switch between MIDs is now displaying as expected.

Everything is back to normal. If you're still seeing any issues, a quick browser hard refresh or cache clear should sort it out. Thank you so much for your patience while we worked through this, and we apologize for any inconvenience it may have caused.
Posted Sep 14, 2026 - 15:13 EDT

Investigating

We're currently aware of a service disruption affecting the Bridge portal, where the label dropdown used to switch between MIDs isn't displaying for some users.

Our team is actively looking into this to understand the full impact and restore functionality as quickly as possible. We truly appreciate your patience and apologize for any inconvenience this may cause.

We'll share an update as soon as we have more to report.
Posted Sep 14, 2026 - 15:07 EDT
This incident affected: Bridge (Bridge UI).