The issue affecting certain Mastercard transactions has been resolved, and transaction processing is now functioning normally.
Our engineering teams will continue to monitor the environment to ensure ongoing stability. We appreciate your patience and understanding throughout this incident.
If you continue to experience any related issues, please contact our support team with recent transaction details for further investigation.
Posted May 13, 2026 - 05:38 EDT
Monitoring
Our engineering teams have rolled out fixes related to the ongoing Mastercard transaction issue, and transaction processing is now functioning normally.
We are continuing to closely monitor the environment to ensure system stability. If you are still experiencing any impact, please contact our support team and share recent examples for further investigation.
We appreciate your patience and understanding throughout this incident.
Posted May 13, 2026 - 05:29 EDT
Identified
We are currently experiencing an issue affecting certain Mastercard transactions. Our engineering teams are actively engaged and working toward a resolution.
We will continue to provide updates as our investigation progresses and as we work toward a resolution. We sincerely apologize for any disruption this may cause and appreciate your patience.
Posted May 13, 2026 - 04:48 EDT
This incident affected: Payouts US/CA (Transaction Processing) and Payouts EU (Transaction Processing).