API Latency and Timeouts

Incident Report for ConnexPay

Resolved

We are pleased to inform you that the issue causing intermittent system disruptions has been fully resolved. Our systems are now stable and operating normally.

Thank you for your patience and understanding throughout this process. Should you experience any further issues or have any questions, please feel free to reach out to us.
Posted Sep 12, 2025 - 16:25 EDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Sep 12, 2025 - 16:03 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 15:54 EDT

Investigating

We are currently investigating intermittent API failures and overall service instability affecting some requests. Our Engineering, Infrastructure, and Data teams are actively engaged in identifying the root cause and working toward a resolution
Posted Sep 12, 2025 - 15:17 EDT
This incident affected: Payouts US/CA (Purchases API), PayIns US (Sales API), Payouts EU (Purchases API), and PayIns EU (Sales API).