Performance Issues with APIs and Bridge UI

Incident Report for ConnexPay

Resolved

We are pleased to inform you that the issue causing intermittent system disruptions has been fully resolved. Our systems are now stable and operating normally.

Thank you for your patience and understanding throughout this process. Should you experience any further issues or have any questions, please feel free to reach out to us.
Posted Sep 09, 2025 - 12:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2025 - 12:03 EDT

Investigating

We are continuing to investigate this issue.
Posted Sep 09, 2025 - 11:42 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 09, 2025 - 11:34 EDT

Update

We are continuing to investigate this issue.
Posted Sep 09, 2025 - 10:46 EDT

Investigating

We are currently investigating intermittent API failures and overall service instability affecting some requests. Our Engineering, Infrastructure, and Data teams are actively engaged in identifying the root cause and working toward a resolution
Posted Sep 09, 2025 - 10:41 EDT
This incident affected: Bridge (Bridge API, Bridge UI), Payouts US/CA (Purchases API), and Payouts EU (Purchases API).