Card processing degraded — Mastercard transactions

Incident Report for ConnexPay

Resolved

Mastercard transaction processing has returned to normal and remained stable. This incident is now resolved. We apologize for any disruption this may have caused.
Posted Aug 15, 2026 - 01:37 EDT

Identified

Mastercard transaction processing is recovering. We're continuing to monitor closely to confirm full resolution before closing this incident.
Posted Aug 15, 2026 - 01:35 EDT

Investigating

We are investigating intermittent failures processing Mastercard transactions. Some transactions may be delayed or declined. Other card networks are unaffected. We are aware of an issue affecting Mastercard transaction processing and are investigating.
Posted Aug 15, 2026 - 01:00 EDT
This incident affected: Payouts US/CA (Transaction Processing) and Payouts EU (Transaction Processing).